Stratux Europe Edition

Forum - Technik & Flugzeuge
  • Hallo zusammen,

    klinke mich jetzt auch in diese Diskussion mit ein, da ich gerne weitere Erfahrungen sammeln möchte.
    Tom Bric hat mir bis hierhin schon sehr viel geholfen, danke nochmal dafür!

    Habe den Stratux-Radar-Display mit OLED zusammengebaut und software-technisch fast zu Ende eingerichtet und konfiguriert.
    --> Stratux mit Version eu030 / T-beam mit GxAirCom.

    Jetzt wird am OLED-Display aber immer noch "no GPS" und die erkannten Flugzeuge nur als Ringe angezeigt.
    Der Stratux hat zwar die korrekte Position/Höhe, aber keine Satelliten, der GxAirCom hat Satelliten empfangen !?

    Tom Bric hat mir empfohlen das Trouble-Shooting zu machen oder alternativ auf OGN wechseln, und ggf., wenn alles funktioniert, wieder GxAirCom anschalten.

    Hatte jemand das Problem auch oder besser noch ... kennt die Lösung?

    Grüße.

  • Bei meinem 1090 SDR bekomme ich seit neuestem folgenden Fehler:

    root@stratux:/home/pi# sdrs
    No supported devices found.
    No supported devices found.

    Ist das Teil defekt oder kann man dem wieder Leben einhauchen? Es leuchtet zumindestens wenn es angeschlossen ist.

  • FlyingRaki schrieb:

    Bei meinem 1090 SDR bekomme ich seit neuestem folgenden Fehler:

    root@stratux:/home/pi# sdrs
    No supported devices found.
    No supported devices found.

    Ist das Teil defekt oder kann man dem wieder Leben einhauchen? Es leuchtet zumindestens wenn es angeschlossen ist.

    was gibt denn 

    lsusb

    aus (ist ein kleines L der erste Buchstabe)

    dazu auch gerne auch

    tail -f /var/log/syslog

    dann den Stick raus und reinstecken, warten und das log gerne mal zeigen

  • HansOtto schrieb:
    FlyingRaki schrieb:

    Bei meinem 1090 SDR bekomme ich seit neuestem folgenden Fehler:

    root@stratux:/home/pi# sdrs
    No supported devices found.
    No supported devices found.

    Ist das Teil defekt oder kann man dem wieder Leben einhauchen? Es leuchtet zumindestens wenn es angeschlossen ist.

    was gibt denn 

    lsusb

    aus (ist ein kleines L der erste Buchstabe)

    dazu auch gerne auch

    tail -f /var/log/syslog

    dann den Stick raus und reinstecken, warten und das log gerne mal zeigen

    Output lsusb:

    lsusb
    Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

    Beim Log passiert nach dem raus und wieder einstecken innerhalb von 3 Minuten nichts:

    root@stratux:/home/pi# tail -f /var/log/syslog
    Apr 4 15:43:06 stratux systemd[806]: Listening on GnuPG cryptographic agent and passphrase cache (access for web browsers).
    Apr 4 15:43:06 stratux systemd[806]: Listening on GnuPG cryptographic agent and passphrase cache (restricted).
    Apr 4 15:43:06 stratux systemd[806]: Listening on GnuPG cryptographic agent (ssh-agent emulation).
    Apr 4 15:43:06 stratux systemd[806]: Listening on GnuPG cryptographic agent and passphrase cache.
    Apr 4 15:43:06 stratux systemd[806]: Reached target Sockets.
    Apr 4 15:43:06 stratux systemd[806]: Reached target Basic System.
    Apr 4 15:43:06 stratux systemd[806]: Reached target Main User Target.
    Apr 4 15:43:06 stratux systemd[806]: Startup finished in 369ms.
    Apr 4 15:43:06 stratux systemd[1]: Started User Manager for UID 1000.
    Apr 4 15:43:06 stratux systemd[1]: Started Session 1 of user pi.

    Wenn ich das gleiche mit dem 978er mache sieht es so aus:

    root@stratux:/home/pi# lsusb
    Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 001 Device 003: ID 0bda:2838 Realtek Semiconductor Corp. RTL2838 DVB-T
    Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

    root@stratux:/home/pi# tail -f /var/log/syslog
    Apr 4 15:42:26 stratux systemd[806]: Reached target Main User Target.
    Apr 4 15:42:26 stratux systemd[1]: Started User Manager for UID 1000.
    Apr 4 15:42:26 stratux systemd[806]: Startup finished in 388ms.
    Apr 4 15:42:26 stratux systemd[1]: Started Session 1 of user pi.
    Apr 4 15:42:56 stratux dnsmasq-dhcp[618]: DHCPDISCOVER(ap0) 192.168.10.35 60:f2:62:1c:91:1b
    Apr 4 15:42:56 stratux dnsmasq-dhcp[618]: DHCPOFFER(ap0) 192.168.10.35 60:f2:62:1c:91:1b
    Apr 4 15:42:56 stratux dnsmasq-dhcp[618]: DHCPREQUEST(ap0) 192.168.10.35 60:f2:62:1c:91:1b
    Apr 4 15:42:56 stratux dnsmasq-dhcp[618]: DHCPACK(ap0) 192.168.10.35 60:f2:62:1c:91:1b C11-J5OUTWNI7F7
    Apr 4 15:43:09 stratux systemd[1]: Started Session 3 of user pi.
    Apr 4 15:43:28 stratux kernel: [ 111.366422] usb 1-1.2: USB disconnect, device number 3
    Apr 4 15:43:28 stratux kernel: [ 111.589164] usb 1-1.2: new high-speed USB device number 4 using xhci_hcd
    Apr 4 15:43:29 stratux kernel: [ 111.701223] usb 1-1.2: New USB device found, idVendor=0bda, idProduct=2838, bcdDevice= 1.00
    Apr 4 15:43:29 stratux kernel: [ 111.701255] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    Apr 4 15:43:29 stratux kernel: [ 111.701271] usb 1-1.2: Product: NESDR Nano 2+
    Apr 4 15:43:29 stratux kernel: [ 111.701286] usb 1-1.2: Manufacturer: Nooelec
    Apr 4 15:43:29 stratux kernel: [ 111.701299] usb 1-1.2: SerialNumber: stx:978:0
    Apr 4 15:43:29 stratux mtp-probe: checking bus 1, device 4: "/sys/devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.2"
    Apr 4 15:43:29 stratux mtp-probe: bus: 1, device: 4 was not an MTP device
    Apr 4 15:43:29 stratux mtp-probe: checking bus 1, device 4: "/sys/devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.2"
    Apr 4 15:43:29 stratux mtp-probe: bus: 1, device: 4 was not an MTP device
    Apr 4 15:43:33 stratux kernel: [ 116.487182] usb 1-1.2: USB disconnect, device number 4
    Apr 4 15:43:51 stratux kernel: [ 134.549143] usb 1-1.2: new high-speed USB device number 5 using xhci_hcd
    Apr 4 15:43:51 stratux kernel: [ 134.661215] usb 1-1.2: New USB device found, idVendor=0bda, idProduct=2838, bcdDevice= 1.00
    Apr 4 15:43:51 stratux kernel: [ 134.661249] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    Apr 4 15:43:51 stratux kernel: [ 134.661265] usb 1-1.2: Product: NESDR Nano 2+
    Apr 4 15:43:51 stratux kernel: [ 134.661280] usb 1-1.2: Manufacturer: Nooelec
    Apr 4 15:43:51 stratux kernel: [ 134.661293] usb 1-1.2: SerialNumber: stx:978:0
    Apr 4 15:43:51 stratux mtp-probe: checking bus 1, device 5: "/sys/devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.2"
    Apr 4 15:43:51 stratux mtp-probe: bus: 1, device: 5 was not an MTP device
    Apr 4 15:43:52 stratux mtp-probe: checking bus 1, device 5: "/sys/devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.2"
    Apr 4 15:43:52 stratux mtp-probe: bus: 1, device: 5 was not an MTP device
  • So wie es ausieht ist der SDR defekt, er wird ja nicht mal als USB Gerät angezeigt.

    MIt glück, ist auf einfach nur der USB Stecker verdreckt (oder ein Pin drin verbogen) so das nur die Strom Pins gehen, deshalb die LED.

    Edit: beim anderen SDR, kommt noch ein Gerät dazu, ein USB Hub? ist der Wirklich mit dazu bekommen?

    dazu bitte mal

    lsusb -t

    ausführen, dann sieht man die Verkettung der USB Devices

  • HansOtto schrieb:

    Edit: beim anderen SDR, kommt noch ein Gerät dazu, ein USB Hub? ist der Wirklich mit dazu bekommen?

    dazu bitte mal

    lsusb -t

    ausführen, dann sieht man die Verkettung der USB Devices

    Ich hab ne USB Verlängerung dazwischen, also ja. Hab aber alles auch schon beim 1090 ohne ausprobiert mit dem gleichen Ergebnis.
    root@stratux:/home/pi# lsusb -t
    /: Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/4p, 5000M
    /: Bus 01.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/1p, 480M
        |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/4p, 480M
            |__ Port 2: Dev 3, If 0, Class=Vendor Specific Class, Driver=usbfs, 480M
  • Für die, die Probleme hatten mit der Version EU030 ihren T-Beam zu konfigurieren:

    Hier gibt es relativ ausführliche Analyse zum Problem. Was genau die Ursache ist, weiß ich bisher leider noch nicht. Aber wer will (und entsprechende Fähigkeiten hat) kann sich gerne hier beteiligen: https://github.com/b3nn0/stratux/issues/278

  • Hallo erstmal an dieses Forum.

    Ich habe mir ein Stratux EU mit 2 NooElec Nano 2+ und einem T-Beam V1.2 (Der V1.1 mit AXP2101 Power Chip) gebaut. 

    Zusätzlich habe ich mir eine bessere (28db 25x25mm) GPS Antenne gekauft und alles in ein Gehäuse verbaut. 

    OGN Tracker funktioniert ja leider mit dem T-Beam V1.2 nicht, GXAircom habe ich gar keine Satelliten empfangen können. Allerdings habe ich mit SoftRF V1.3 sehr guten Empfang auf dem T-Beam.

    Dies wird mir auch in SkyDemon so angezeigt. Allerdings zeigt mein Flugzeug immer nach oben und die Zeitenanzeige kommt nicht. Außerdem wird mir im GUI nicht angezeigt wie genau das GPS Signal ist.

    Hier noch ein paar Screenshots: 



    Ist das ganze ein Konfigurationsproblem? Ich hoffe es sehr :-) 

    Ich hoffe, dass wir das Problem finden. Sonst werde ich wahrscheinlich das Flarm Out (ergo: T-Beam) gegen ein simplen GPS Empfänger tauschen. 

    Grüße

  • Ist ein known issue, werde voraussichtlich nächstes Wochenende eine neue Version mit einem Fix veröffentlichen.

    Falls mit deiner app möglich: das sollte nur passieren wenn du GDL90 verwendest. Bei NMEA basierter Verbindung passiert das nicht.

    Du solltest aber in jedem Fall auf das aktuellste SoftRF aktualisieren. Alte Versionen senden ein veraltetes Flarm Protokoll. Flarm Geräte können das nicht mehr empfangen.

  • Unterstützt SoftRF tatsächlich inzwischen das neue FLARM Protokoll??

Jetzt anmelden

Passwort vergessen

Umfrage Archiv

Wie häufig haltet Ihr die Halbkreisflugregel ein?

Eher häufig!
36.4 %
Immer!
30.2 %
Hin und wieder!
17.1 %
Nie!
9.5 %
Eher selten!
6.9 %
Stimmen: 275 | Diskussion
Anzeige: Roland Aircraft
Statistik Alle Mitglieder

Aktuell sind 7 Besucher online.

Anzeige: EasyVFR